Could not find a version that satisfies the requirement tensorflow

I installed the latest version of Python (3.6.4 64-bit) and the latest version of PyCharm (2017.3.3 64-bit). Then I installed some modules in PyCharm (Numpy, Pandas, ...), but when I tried installing Tensorflow it didn't install and I got the error message:

Could not find a version that satisfies the requirement tensorflow (from versions: ) No matching distribution found for tensorflow

Then I tried installing tensorflow from the command prompt and I got the same error message. I did however successfully install tflearn.

I also installed Python 2.7 but I again got the same error message. I googled the error and tried some of the things which were suggested to other people but nothing worked (this included installing Flask).

How can I install Tensorflow? Thanks.

Tensorflow as of Aug-13-2018 supports, Python 3.6.x . Install Python 3.6.x

From: stackoverflow.com/q/48720833