Error: Microsoft Visual C++ 10.0 is required (Unable to find vcvarsall.bat)

Im trying to install numpy with PyCharm but i keep getting this error:

error: Microsoft Visual C++ 10.0 is required (Unable to find vcvarsall.bat).

Can someone please explain to me exactly what i have to do to fix this error(and as simple and detailed as possible)? im using python 3.4.2 (i know this has been answered before but i did not understand it).

I got the same error and ended up using a pre-built distribution of numpy available in SourceForge (similarly, a distribution of matplotlib can be obtained).

Builds for both 32-bit 2.7 and 3.3/3.4 are available.
PyCharm detected them straight away, of course.

From: stackoverflow.com/q/28251314

Back to homepage or read more recommendations: